Support Center

Mojave Compatibility with V4

Last Updated: Jun 05, 2019 03:51PM EDT
At this time, we advise users who currently use Soundtoys Native and TDM FX V4 to refrain from upgrading their MacOS beyond 10.13. Some changes in Apple's graphics handling has caused certain colors to be displayed differently making it harder or impossible to see the readouts on the plugins' LED readouts.

A workaround is possible by using your DAW's built-in automation controls to set values, although this is obviously not ideal, and in some cases no more informative (ie. multi-function boxes like EchoBoy's delay time knob).

We do not have plans to issue any upgrades for our legacy products, so we advise not to upgrade your MacOS unless you also have plans to permanently use Soundtoys 5.

If you have any questions or concerns, please submit a ticket here so that our Support Team can help you.